Intermittent performance issue
Incident Report for Mobilize
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 18:37 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 08, 2024 - 18:36 EDT
Investigating
We are currently investigating reporting slowness and errors for some users utilizing mobilize.us and its API.
Posted Oct 08, 2024 - 17:56 EDT
This incident affected: Website and API.