Links in emails are broken
Incident Report for Mobilize
Resolved
This incident has been resolved and links should all function properly at this time
Posted Aug 27, 2021 - 13:43 EDT
Monitoring
We have deployed a workaround fix and believe email links are now working. We are monitoring for further issues and asking for more input from our email provider.
It may take a few minutes for browsers with cached data to see the updated (fixed) version
Posted Aug 27, 2021 - 12:26 EDT
Investigating
We are currently investigating an issue where links in emails are broken. We believe this to be an issue with our email provider, Mailgun, and are currently investigating both the source of the errors and how we can bypass the provider. We will provide updates as soon as we know more.
Posted Aug 27, 2021 - 12:16 EDT
This incident affected: Website.