Intermittent performance issue

Incident Report for Mobilize

Resolved

A fix has been implemented.
Posted Apr 04, 2025 - 18:20 EDT

Identified

Elevated API traffic is contributing to slowness on Mobilize.us. Users may receive "Server Error" messages when creating or editing events.
Posted Apr 04, 2025 - 16:05 EDT
This incident affected: Website and API.