Intermittent performance issue
Incident Report for Mobilize
Resolved
As of 8:30 pm ET, this incident has been resolved.
Posted Oct 14, 2024 - 20:36 EDT
Monitoring
Some users of Mobilize.us and its API may encounter slowness on the site or intermittent Cloudflare loading pages.
Posted Oct 14, 2024 - 19:28 EDT
Investigating
As of 5:45 pm ET, we are investigating reports of slowness and errors for some users utilizing mobilize.us and its API.
Posted Oct 14, 2024 - 17:58 EDT
This incident affected: Website and API.