Email sending delayed
Incident Report for Mobilize
Resolved
We are seeing email send times return to normal.
Posted Oct 29, 2020 - 18:21 EDT
Identified
Due to high volume, some email sending may be delayed. We're working on increasing throughput.
Posted Oct 29, 2020 - 18:07 EDT
This incident affected: Notifications (Email).