Degraded email send performance
Incident Report for Mobilize
Resolved
We are not longer experiencing high email delivery times. The issues our upstream vendor were facing were reported as resolved as of 12:08 EDT.
Posted Jun 09, 2022 - 12:30 EDT
Identified
We are currently experiencing high email delivery times due to issues with an upstream vendor. This is affecting all emails, including login links, exports, and notifications (upwards of 20+ minutes). We are investigating a workaround and will update as our email capabilities come back online.
Posted Jun 09, 2022 - 11:28 EDT
This incident affected: Notifications (Email).