Elevated error rate
Incident Report for Mobilize
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 12:18 EST
Investigating
We're experiencing an elevated level of errors on our website and are actively resolving the issue. We are observing loading issues for action feeds at the individual organization level. Mobilize.us continues to operate normally, and supporters can still sign up for events there. Our team is actively working on implementing a fix to address this issue promptly.
Posted Feb 27, 2024 - 11:18 EST
This incident affected: Website.