Intermittent performance issue
Incident Report for Mobilize
Resolved
This incident has been resolved.
Posted Oct 13, 2024 - 15:33 EDT
Monitoring
As of 2:15 pm ET, we have identified and mitigated the cause of slowness and errors reported by some users. We are currently monitoring the performance of the site and its API as we recover.

Some users may receive a page from Cloudflare that they have been blocked. Please refresh and log in again.
Posted Oct 13, 2024 - 14:17 EDT
Update
We are continuing to investigate this issue.
Posted Oct 13, 2024 - 11:36 EDT
Investigating
As of 11:23 ET, we are investigating reports of slowness and errors for some users utilizing mobilize.us and its API.
Posted Oct 13, 2024 - 11:35 EDT
This incident affected: Website and API.