Email newsletter delivery issues
Incident Report for Mobilize
Resolved
This incident has been resolved.
Posted Feb 01, 2024 - 19:22 EST
Monitoring
A fix has been implemented and we are monitoring the newsletter email send.
Posted Feb 01, 2024 - 19:12 EST
Investigating
We are observing email delivery issues for the newsletters and are investigating. All expected emails will be sent, though there may be some delays. Other emails such as for logins are not affected.
Posted Feb 01, 2024 - 19:03 EST
This incident affected: Notifications (Email).